About RPA.MSGraph

Hi Everyone, I am unable to use the Library " RPA.MSGraph" .When i am using it is showing that
"Unresolved library: RPA.MSGraph.
Error generating libspec:
Importing library ‘RPA.MSGraph’ failed: Module ‘RPA’ does not contain ‘MSGraph’.
Consider adding the needed paths to the “robot.pythonpath” setting
and calling the “Robot Framework: Clear caches and restart” action.robotframework
"
can anyone help me with this .

Can you please share with us your conda.yaml and are you using VSCode for running the bot I assume?

Try following the instruction with clearing the envs, then restart the IDE and make sure your VSCode and extensions (Robocorp and Robot Framework) are up-to-date and try again.


For the sake of the testing, try with rcc as well: download page. (if it still fails)

Thanks for your response. I will check that and will update

Hi @cosmin , it is giving same error after trying the instrunction which are provided by you. And please find my Conda.yaml

You need to update your rpaframework, latest is 20.1.0. Reason for error is that MSGraph library was added on version 17.5.0.

1 Like

Thanks @linkraivo, it is working now

1 Like