BrowserNotFoundError: Failed to start a browser

Hello,

I am following the RPA certification level I: Beginner’s course and I am currently stuck on BrowserNotFoundError: Failed to start a browser

I have seen some similar posts in this forum, but none of them seems to provide a clear solution.

I have tried and checked the following solutions, but none of them resolved my issue:

  1. My webdrivers folder is in the PATH
  2. All my webdrivers executable files (chromedriver.exe, etc.) have all permissions (full control)
  3. When I run individual webdrivers in Windows CMD they all start and run without a problem

When I run my robot in VS Code I get the following errors:

Interactive console:

Conda error message:

Web log - part 1:

Web log - part 2:

Are you using our tooling (VS Code and two of our plugins) to setup and run those robots, or are you trying to do things manually?

And note, you should not be using conda directly (or manually), and in our tooling (rcc) is using micromamba instead of conda.

Can you share your conda.yaml and robot.yaml? And if issue persists, could you submit issue report from VS Code directly?

Hi,
That conda activate error comes from VS Code built-in conda detection (added a while back) that automatically tries to do things that make no sense for our setups. That error can be ignored (it only fails but does not affect us), we are looking for a way to get a work-around for that one.

On the actual error what @jippo said holds true, but adding a few of my own :wink:
What browser do you have installed on the machine? That is what browser would you expect to pop-up?
Is there an antivirus scanner involved on this machine? …something is blocking access to the geckodriver that would be used to trigger Firefox.

BR, Kari

Thank you both for your super fast reply!

I have actually managed to resolve the issue by simply installing Chrome on my machine and now everything works just fine.

Before I installed the Chrome I had only Edge and Vivaldi installed on my machine which I expected to be enough. My mistake was that I did not read the system requirements page first.

What made me believe that my two already installed browsers should be enough was the following statements from the RPA.Browser.Selenium documentation page

Hi @Kari,
I was and still having this same problem with Edge browser.
Only chrome opens but why Edge won’t.
I wanted to Automate Edge.
I am using in VSCode with Robocorp Extensions and both chrome and edge is installed in my system.
I’ve raised this same issue but no one answered😥.
Any help here.

@Master_B here are few ideas for you:

  • are you using RPA.Browser.Selenium library
  • you could try to use RPA.Browser.Selenium library keywords Open Browser directly using edge as browser value
  • when you get concrete error, report back with that error, your conda.yaml, robot.yaml and your robot code, so that we can more clearly see what is going on