Can't get Conversion Accelerator to work (UiPath Project to Robocorp)

Hi, I keep getting error messages with the Conversion Accelerator.

I have my project.json and all of the .xaml files in a folder. Here is a screenshot of the folder I am trying to run the conversion tool on:

When I run the converter, I get the error message:

I’m a bit stuck here.

If I’m missing certain files, for instance if I take the LocationScreenshots.xaml out fo the folder I get the message:

But as soon as I put it back in I’m back to the try catch error.

I could really use some help with this as we are attempting to fully integrate our UiPath projects over to Robocorp.

1 Like

Hi @dburkhart

thanks for your interest in RCA.

It’s a case we didn’t consider yet. I have already pushed a quick fix that should fix this particular problem (please let me know if it does not work). If you close and reopen VSCode, you should be asked if you want to update the converter (yes).

@marco Thanks for the response, I updated VS code and am now getting the error:

Error: Expected at least one branch for a try-catch block

@dburkhart it sounds like something new. Is there any chance you could share that bot with us in private? If so, my email is my nickname followed by robocorp dot com.

Hi @dburkhart, we fixed the problem. If you update the converter version in vscode, you should be able to test your bot.

Hi @marco,

I am still running into the error. I have reset VS Code multiple times and I am using the same folder that I sent to you and am still getting the try catch error…

Here are the contents of the folder I am selecting:

Here is the converter setup I am attempting with the error:

Am I doing something wrong here?

Hi @dburkhart

has vscode asked you if you want to update the converter? When you open the converter view, there is a small popup telling that there is a new version available. You may need to close and reopen vscode.

1 Like

Weird, it wasn’t showing up before but it showed today.

Thank you for all of your help!

1 Like

Glad the problem is solved. Let me know if I can help any further.

Thanks for raising the issue. Feedback on RCA is more than appreciated!