Click method not working


I am using above library and trying a automate scenario for Adobe Reader software . Unfortunately click method is not working , Mouse is trying to move to that element but it is not clicking

Below is my script -

Windows Run AcroRd32.exe
Control Window Adobe Acrobat Reader DC (32-bit)
Click type:MenuBar and name:“Application” > type:MenuItem and index:1

Windows Element are correct they are not getting failed only Action is not happening , If i use SendKeys instead of this then it is clicking the button (but gives error as well as it is not input button) , I use same code on other machine it is working fine , Is there any settings in a computer which can block the mouse events to trigger.

Just tested with this example on a Windows 11 ARM (emulated on an M1 Mac) and it works just fine with your example (adapted to 64bit), here’s a video recording.

Identifying the locator:

End result:

Btw, why are you using that crazy complex locator when a Click File will work just fine? Try with that, might be more flexible no matter the platform and Acrobat version you’re using.

Hi @cosmin Thanks for the help.

There are 2 different problems here →

  1. Want to understand is RPA.Windows library compatible in automating 32 bit software on 64 bit OS system? if for above problem if you will use 32 bit Adobe Acrobat Reader then locator you are suggesting wont work i.e Click File , I tried this locator on 64bit Adobe Acrobat Reader it worked .

Just giving few examples were people facing issues with mouse clicks which are not direct link to but somewhat problem is similar:

  1. Coming to my problem , this is more specific to machine which i am using in corporate network which has certain restriction in terms of security though i am executing my code in admin mode but still the click is not happening if i use my personal machine then click is working. So my questions was is there any OS settings which could block mouse events to happen and are mouse events depends on the drivers installed . My is Window 10 HP laptop.
1 Like

@cosmin Just to highlight here my problem is solved now please include in your documentation for troubleshooting : I think problem here was something else , now it looks like everything is working as expected even in my corporate network. So the main problem was screen layout it was to 150% by default and i made it 100% now everything is working as expected Windows element are getting recognized.


1 Like

Thank you, that’s very valuable! And to be frank, I would have never guessed this path. (and I’m glad you fixed it yourself)

Here’s an Issue I created for it.

1 Like