Error when using RPA.Dialogs

Hi, I’m trying tu use the RPA.Dialogs library but when I executes my task, I have this error message:
You must have either QT or GTK with Python extensions installed in order to use pywebview.

I think my conda packages are not well set.
Do you know what dependencies I should install in order to use RPA.Dialogs?

Thanks

Hi,

Can you share your conda.yaml -file and what OS are you running on. Dialogs depend on some system-level stuff to be able to view the dialogs and these have been bothering us on different platforms.

BR, Kari

I use Debian 10 and my conda file is:

channels:
  - conda-forge

dependencies:
  - python=3.9
  - nodejs=14.17.4
  - qt=5.12.9
  - pyqt=5.12.3
  - pyqtwebengine=5.12.1

  - pip=20.1
  - pip:
    - rpaframework==12.2.0 # https://rpaframework.org/releasenotes.html
    - robotframework-browser==11.1.0
    - pyqt5
    - pywebview
    - pywebview[qt]
    
rccPostInstall:
  - rfbrowser init

One thing to avoid here is to have duplicates in the conda and pip sections.

Pip just basically overwrites dependencies quite brutally and can break things.
So I’d first drop the pyqt5, pywebview and pywebview[qt] as you should be getting those already in the dependencies section.

On Linux the dialogs need either Qt or GTK as the error says but I cannot directly see why the qt from conda-forge is not enough… We have limited our Linux testing to Ubuntu as there are so many options, so I do not have info on Debian side.

But I would first drop the duplicates as taking those could easily result in a broken Qt setup for example.
BR, Kari

FYI, I tried this without success (same error message):

channels:
  - conda-forge

dependencies:
  - python=3.9
  - nodejs=14.17.4
  - qt=5.12.9
  - pyqt=5.12.3
  - pyqtwebengine=5.12.1
  - pip=20.1
  - pip:
    - rpaframework==12.2.0 # https://rpaframework.org/releasenotes.html
    - robotframework-browser==11.1.0
    
rccPostInstall:
  - rfbrowser init

I finally use “Dialogs” library instead with success.

Hi @apal
…sorry for the holiday’s silence.

What was the final fix to this? I’m assuming we will hit this with other people using Debian as well.

BR, Kari