Everything needs to be written in one cell

I noticed this on 3 different laptops so I really don’t think that it is some kind of a cache issue or anything.
Every Settings, Keywords and Tasks has to be in one cell, otherwise nothing will run.
So writing a keyword in one cell and using it in another cell’s keyword is not possible.
Am I missing something?

Hi @turigergely88 and welcome to the forum!

That should not be the case. You should be able to split the code in multiple cells - as long that you don’t split one keyword/task into multiple cells.

Here is a super simple example:

Could you try the following:

  1. create two cells and type the above code into those
  2. select the first cell (by clicking inside it) and press SHIFT+ENTER - that will make the cell available in Robot Framework for other cells to use. As a visual clue that cell has been “updated” in Robot Framework interpreter, you should see [1] on the left side of the cell and “My keyword” button for running that single keyword should appear below the cell.
  3. repeat the SHIFT+ENTER for the second cell - this should already execute the whole process and produce a log file

There is a catch that cells that contain Settings, Variables or Keywords are not run with SHIFT+ENTER, but only updated in the Robot Framework interpreter for later use. While cells that contains Tasks is immediately run with SHIFT+ENTER. This concept is similar in python and Robot Framework notebooks - python functions are just stored to python interpreter, but they are not automatically called.

If this is not working, do you get some error messages?

Hi,

thank you for your answer.
I found out what the “problem” was.
If you just create a robot, write a keyword and/or a task and you don’t run all the cells at least once, including the one with the Documentation and Libraries, then you will get “No keyword with name ‘…’ found”.
So it doesn’t automatically run all cells the first time, but once all have been run you can add more cells without having to worry about any error mesages.

:+1: Great!

…and if you edit your keyword, you must re-run the cell for changes to “take-effect”.