Fixing problem: TypeError: Subscripted generics cannot be used with class and instance checks

The robotframework version 4.0.1 is causing this error ( TypeError: Subscripted generics cannot be used with class and instance checks) and that version has been excluded from rpaframework version 9.5.0 onwards.

The possible rpaframework versions which might be getting this error are: 9.0.0 → 9.4.0.

Error can be fixed by upgrading rpaframework to 9.5.0 or by setting robotframework to 4.0.0 version.

Fix for robotframework is scheduled as a priority fix and should be available shortly.

2 Likes