Freezing execution on RDP


I have an automation that runs in pure python and uses selenium library to run IE.
The automation when I ran local worked, but when I put on robocorp to run using a VM, after 3 cases the execution freeze. If I access the VM there’s no actions, the robocorp don’t rise any error and the execution stay running on control room.

It happened in 2 automations that have similiar scripts, and observing the log I found a possibility to the problem, the function quit() from selenium was the last line that run in the 2 automations with this error.

The problem was not have problem on execution, but freeze and nos return any error and the VM stay Busy

The bot runs until KMM.payment, the log confirm this

All resources that your code uses/reserves, are they also released? Do you close all browsers and applications used, and shutdown everything? So no processes are left hanging as “zombies”?

The problem is in the command line webdriver.quit(), apparently the webdriver had problem to end the instance and freeze, I try to kill the process with cmd and the control room returns to log

Is quit() throwing an error or is it just freezing?

Just freezing, it’s like selenium wants to end the instance but can’t, I gonna try use task kill