Hi Unable to get or Create Standard Roboto Framework Template

Hi Team, As part of Developer training level 1, i have build basic process using Standard Robot Framework, day before yesterday i have tried to change Task.robot name as my desire name and i have save after that am not able to get robot files in vs code , not able to create new robot.i have uninstalled complete robocrop files and installed again tried this few times as guided in beginner course and tried updating PiP, python and vs code am able to install robocrop extensions still am not able to get the Standard robot framework , i have checked in templates folders its empty and not able to clear and refresh frame work server language and am getting from robocrop language server , please find the error screen shots and erros below and appreciated if some could help to over come this issue, Thanks in Advance.

Plugins dir: /Users/sowdavarambalaji/.vscode/extensions/robocorp.robocorp-code-0.39.0/src/robocorp_code/plugins.
Getting language server Python executable.
Waiting for RobotFramework (python) Language Server to finish activating…
Starting RobotFramework Language Server with args: /Users/sowdavarambalaji/Documents/RoboCrop,-u,/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/src/robotframework_ls/main.py,-v
[Error - 6:15:13 PM] Robot Framework Language Server client: couldn’t create connection to server.
Error: Launching server using command /Users/sowdavarambalaji/Documents/RoboCrop with args: -u,/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/src/robotframework_ls/main.py,-v failed.
at serverOptions (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/extension.js:291:19)
at async LanguageClient.createConnection (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/node_modules/vscode-languageclient/lib/common/client.js:1030:28)
at async LanguageClient.start (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/node_modules/vscode-languageclient/lib/common/client.js:612:32)
at async startLanguageServer (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/extension.js:371:5)
at async /Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/extension.js:702:44
at async Mutex.dispatch (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/mutex.js:21:20)
at async activate (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/extension.js:676:5)
at async w._activate (/Users/sowdavarambalaji/Documents/Visual Studio Code.app/Contents/Resources/app/out/vs/workbench/api/node/extensionHostProcess.js:90:8304)
at async w._waitForDepsThenActivate (/Users/sowdavarambalaji/Documents/Visual Studio Code.app/Contents/Resources/app/out/vs/workbench/api/node/extensionHostProcess.js:90:8246)
at async w._initialize (/Users/sowdavarambalaji/Documents/Visual Studio Code.app/Contents/Resources/app/out/vs/workbench/api/node/extensionHostProcess.js:90:7610)
It was not possible to start the Robot Framework Language Server. Please update the related robot.language-server configurations.
Launching server using command /Users/sowdavarambalaji/Documents/RoboCrop with args: -u,/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/src/robotframework_ls/main.py,-v failed.
Error: Launching server using command /Users/sowdavarambalaji/Documents/RoboCrop with args: -u,/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/src/robotframework_ls/main.py,-v failed.
at serverOptions (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/extension.js:291:19)
at async LanguageClient.createConnection (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/node_modules/vscode-languageclient/lib/common/client.js:1030:28)
at async LanguageClient.start (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/node_modules/vscode-languageclient/lib/common/client.js:612:32)
at async startLanguageServer (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/extension.js:371:5)
at async /Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/extension.js:702:44
at async Mutex.dispatch (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/mutex.js:21:20)
at async activate (/Users/sowdavarambalaji/.vscode/extensions/robocorp.robotframework-lsp-1.5.0/vscode-client/out/extension.js:676:5)
at async w._activate (/Users/sowdavarambalaji/Documents/Visual Studio Code.app/Contents/Resources/app/out/vs/workbench/api/node/extensionHostProcess.js:90:8304)
at async w._waitForDepsThenActivate (/Users/sowdavarambalaji/Documents/Visual Studio Code.app/Contents/Resources/app/out/vs/workbench/api/node/extensionHostProcess.js:90:8246)
at async w._initialize (/Users/sowdavarambalaji/Documents/Visual Studio Code.app/Contents/Resources/app/out/vs/workbench/api/node/extensionHostProcess.js:90:7610)

Hi @amsamtej,

A bit unclear what is happening here but a few pointer. If you change the name of tasks.robot file you probably need to check the robot.yaml configuration. Depending on the setup the task command there can point to the tasks.robot -file specifically.

You should not be updating python or pip or anything on the machine itself.
What is the templates -folder you are referring to?

The errors to me look like maybe you have only the LSP extension setup. My recommendation is to just setup the two extensions from VS Code extensions panel.
image
…the versions (at the time of writing this) should be Robocorp Code v0.39.0 and Robot Framework Language Server v1.5.0

BR, Kari