How to get past long filename error in VSCode on Win2016

I’ve installed the robocorp extension in VSCode, but it won’t start because windows long pathname support isn’t enabled. Enabling it doesn’t work, but I remember seeing someplace a way to get around it, but I can’t find the thread anywhere (not even sure which site I saw it on). Doesn’t anyone know how to bypass that error?

Hi, although I’m not sure if you tried all the steps described below, here are some resources I found:

And from rcc:

  • rcc configure longpaths --enable (with admin rights)
  • rcc config diagnostics (checks problems caused by system settings)

It is known that Windows Server 2016 has some issues with it, but hopefully the workarounds above will fully enable the fix.

1 Like

That worked! Thanks, i searched for a long while and somehow missed it.

1 Like