Importing library 'RPA.Browser.Selenium' failed

Hi,

From yesterday I started to receive these errors in my bots.

[ ERROR ] Error in file '/Volumes/BrunoSSD/rpa/rpa-smartbot/cocina-de-sofy-robot-split-orders/tasks.robot' on line 5: Importing library 'RPA.Browser.Selenium' failed: ImportError: cannot import name 'ChromeType' from 'webdriver_manager.core.utils' (/Users/Shared/robocorp/ht/86f8cb9_b1f3c24_6133770e/lib/python3.11/site-packages/webdriver_manager/core/utils.py)
Traceback (most recent call last):
  File "/Users/Shared/robocorp/ht/86f8cb9_b1f3c24_6133770e/lib/python3.11/site-packages/RPA/Browser/__init__.py", line 3, in <module>
    from RPA.Browser.Selenium import Selenium as _Selenium
  File "/Users/Shared/robocorp/ht/86f8cb9_b1f3c24_6133770e/lib/python3.11/site-packages/RPA/Browser/Selenium.py", line 50, in <module>
    from RPA.core import webdriver as core_webdriver
  File "/Users/Shared/robocorp/ht/86f8cb9_b1f3c24_6133770e/lib/python3.11/site-packages/RPA/core/webdriver.py", line 19, in <module>
    from webdriver_manager.core.utils import ChromeType, get_browser_version_from_os
PYTHONPATH:
  /Volumes/BrunoSSD/rpa/rpa-smartbot/cocina-de-sofy-robot-split-orders
  /Users/brunoleonardo/.vscode/extensions/robocorp.robotframework-lsp-1.11.0/src/robotframework_debug_adapter
  /Volumes/BrunoSSD/rpa/rpa-smartbot/cocina-de-sofy-robot-split-orders
  /Users/brunoleonardo/.vscode/extensions/robocorp.robotframework-lsp-1.11.0/src
  /Users/brunoleonardo/.vscode/extensions/robocorp.robotframework-lsp-1.11.0/src/robotframework_ls/vendored
  /Users/Shared/robocorp/ht/86f8cb9_b1f3c24_6133770e/lib/python311.zip
  /Users/Shared/robocorp/ht/86f8cb9_b1f3c24_6133770e/lib/python3.11
  /Users/Shared/robocorp/ht/86f8cb9_b1f3c24_6133770e/lib/python3.11/lib-dynload
  /Users/Shared/robocorp/ht/86f8cb9_b1f3c24_6133770e/lib/python3.11/site-packages

I am using this conda.yaml configuration:


channels:
  - conda-forge

dependencies:
  - python=3.11               
  - pip=23.2.1                  
  - pip:
      - rpaframework==24.0.0  
      - msoffcrypto-tool
      - pandas
      - PyMySQL

Hi, use rpaframework==24.1.0. (duplicate of: Chromedriver error - #3 by cosmin)

1 Like