“Intelisense” not working

Hi everyone! I’m trying to connect the library in the Settings block as indicated in the course for beginners, but for some reason the RPA.Browser library is highlighted in green as text. can anyone tell me what is the reason? thanks

Hi, @s.evdokimov! This is what the Settings cell looks like for me:

image

Yes, the library name is shown in green. The colors on our documentation site and in Robocorp Lab don’t match one to one. Does the robot still work, or do you have issues running it?

The auto-completion does not currently work in the Settings section (for libraries etc.) in Robocorp Lab. Hopefully that support will be added soon!

// Jani

Thank you very much for your response. I was confused by the color differences in the font (tutorial and release). And also the fact that there was auto-completion in the training course.

Can you please tell me, can I use all the Robot Framework functionality in Robocorp Lab?

(I mean libraries in the first place)

Yes you can, and Python libraries as well.

Thanks! I will try to transfer the process to Robocorp.

1 Like

Boa tarde @jani , Não entendi… esse recurso intelisense não está implementado apenas para célula Settings , ou não está implementado no momento para nenhuma célula ( Keywords ou Tasks)?

Hi, @ramossuelen139!

The auto-completion keyboard shortcut was changed from TAB to Ctrl+Space in the recent Robocorp Lab release.

You need to type at least two (2) characters, and then press Ctrl+Space:

image

// Jani

Mmm… Ctrl+Space not working for me for auto-completion. Any idea?

I got. Just change the settings at Settings > Advanced Settings Editor > User Preference. Save, restart IDE.

Great platform. Will continue evaluating it for my clients.

2 Likes

Just downloaded yesterday and it seems to work sometimes and not other times for me too. Note, the ctrl space for grabbing a locator also doesn’t always show a plus sign.

Hi, @chiu.leonard and @luckywolf19!

Remember to check out our Visual Studio Code extensions, too (my personal preference since Visual Studio Code has been my go-to IDE for years!):

Hi all!

We are actively improving the autocomplete stability in Lab - there are still some problems with it.

However, sometimes autocomplete is intentionally off for short periods of time while Lab is making changes to the python environment. Typically this happens when robot is opened or conda.yaml is changed. Whenever top right corner says “RCC Working”, autocomplete and cell runs may not work:

1 Like

Alrighty! Will explore it. :+1:t3:

Yes I found out that too. Like @Teppo mentioned in his reply… I’m sure this feature will improves over time.

If you have trouble with autoomplete in Lab, the best tricks you can try are:

  1. Verify RCC Idle
  2. Verify that you have run the *** Settings *** cell (…and libraries have correct name - including lower/upper -case lettering)
  3. Last option is to try closing and restarting the editor

For us C# developers on Visual Studios, any plans to port to it. I have never used VS Code as my teams always used VS normal. Of course, I will give VS Code a try :slight_smile:

No such plans (atm) :pensive: but it all depends on the demand :smile:
We are currently investigating the possibility to port some of the features for Pycharm and/or IntelliJ -family.