MacOS 'Do you want the application "python*" to accept incoming network connection?' pop-up

Hi there,

I’m developing on macOS Monterey Version 12.1 using VS Code Version: 1.63.2 (Universal).

Whenever I execute a robot doing web automation I get the following prompt, while starting Chrome. Haven’t used any other browser, yet, thus I cannot tell if it only happens with Chrome.


It either says ‘python’ or ‘python3’.

The issue is, that I already allow incoming connections for all Python versions I found on my machine in the firewall settings.
Screenshot 2021-12-27 at 03.14.07

As far as I can tell it has not yet affected the robot executions, but it’s terrible annoying.

I found a thread that looks promising, but I’m not sure if I want to sign the python application myself :question:

Hope for your help.

All the best,
Daniel

1 Like

Hi,

Unfortunately, the permissions given to python that you have installed on your machine do not affect this problem.
The RCC toolchain isolates the python environments used from the system so that they cannot break each other. This now causes the Python environments that work behind the VS Code extension to get separate pop-ups like this. As user can have multiple different robots open in VS Code we also have implemented a “round-robin” style re-use of the environment spaces in VS Code which means you would need to get 10 different locations for the python executables when using VS Code.

Same issue exists on Windows and we have not found a clear solution. In Windows, there is no way to give a wildcard to these rules which would make this a lot simpler.
Have to admit I do not know how versatile the rule setup on mac is so we need to check that.
On Windows all these environments for example are placed under:
%localappdata%\robocorp\holotree -folder so so if one could create a rule that handles:
%localappdata%\robocorp\holotree\**\python.exe
…that would be the way to go.

I also know that conda-forge people are working on signing items in the packages… the problem stems from relocation

1 Like

Did a quick test by setting the macOS (Monterey 12.1) firewall to “Block all incoming connections” (as well as the other options) and I was not able to reproduce this case with just web automation like:

This does raise my interest as to what settings would cause this pop-up to come?

BR, Kari

1 Like

Thanks for the answer, @Kari!
What info do you need to evaluate the issue? I can provide them.

Best,
Daniel

In case your setup does not have any specific sensitive settings then I’d be interested just about the screenshot of the settings you have in:
System Preferences > Security & privacy > Firewall > Firewall options...
…or is that screenshot of the rules from some 3rd party firewall?

Also do you get that pop-up if you just run the example robot here:

BR, Kari