No broswer open error in basic certification

Hi. I am in the process of doing the basic certification and have reached the point where I am supposed to automate the login process for maria. I am not sure if this error is part of the test, but whenever I try to run the “Input Text username maria” keyword in the interactive console I get a “No browser is open” error. The page link is Logging into the intranet | Robocorp documentation
and below should be a screenshot of the problem

This error only seems to be present in the interactive console because when I actually added it under my login keyword it worked fine. Any ideas on why it doesn’t load in the console?

The interactive console only runs the exact command you type. It does not remember what you ran before, so any setup you previously did, is lost.
In your case, you did not open a browser in the interactive console (which you should leave open to run commands on that browser) while in your code, you have the “Open the intranet website” inside keywords, which runs before trying to interact with the site.
So, in order for input text to work in interactive console, you would need to:

  • run a command to open your browser and navigate to the site
  • run the input text command

Let me know if it worked.


AH ok thank you so much. Yes this did work

Great. Glad I could help.