No keyword with name 'Open Available Browser' found

Hello,

image

I have installed rpaframework (use ‘pip install rpaframework’).howerver ,when I execute ’ robot xxx.robot ’ in command line mode,failed with error :no keyword with name ‘Open Available Browser’ found

*** Settings ***
Documentation open browser.
Library RPA.Browser

*** Keywords ***
Open The Intranet Website
Open Available Browser www.google.com

*** Tasks ***
open browser with specific url
Open The Intranet Website

it seems that ‘Library RPA.Browser’ did not work.
how to solve this?

Regards,
Higgin

Hi Higgin, Are there only 1 empty space between “Library” and “RPA.Browser” ? It needs at least 2 spaces…

2 Likes

Hi @costa.joaomf,

I’m also facing the same issue as @lxj_ssj_com although I have more than 3 spaces between “Library” and “RPA.Browser”. It was working fine yesterday and the same code is giving me this error now. Below is my code.

Any suggestions would be great.

Thanks in advance.
Vamsi

Hi,

Just to verify: did you run the Settings-cell before? It is easy to forget :slight_smile:

If you did, can you check whether Run robot results in the same message?

Hi @Tim,

Thanks for your response.

Yes, I did run the Settings cell before running the Keywords cell and when I Run Robot, it is opening the browser (as expected) and below popup is not going away.

Thanks for the detailed description. It looks to me like you described this further in the other thread, let us continue there for now.

Hi @vgogineni

Can u restart ur lab again

I faced this issue but restarting it again resolved it

Hello @Nived_Nambiar

Thanks for your reply.

At time I faced this issue, I had to update the lab to the latest version available that time to resolve. Restarting the lab didn’t help me anyway which I did number of times.

Hi,
I’m new to RoboCorp and RF. I have started with beginners course,
but got stuck on step 4 with the same issue:
No keyword with name ‘Open Available Browser’ found.

No luck with restart of Lab app.

Hi @rostislav.pelikan

Use RPA.Browser instead of RPA.Browser.Selenium

RPA.Browser and RPA.Browser.Selenium are aliases pointing to the same library, so both should work (RPA.Browser.Selenium is the preferred alias so as not to confuse with the Playwright-based Browser library).

@rostislav.pelikan : Did you try running the robot with the Run Robot button or the double arrow (>>)? When you add new libraries to the Settings section, you need to evaluate or run that settings cell at least once so that Robocorp Lab parses the import and can find the keywords. If you add a new library and try using keywords from that library before re-evaluating the settings cell, Robocorp Lab does not know about the keywords.

Yes, I did. It started to work the next day without any other change,
so probably restart was needed to correctly load the library.

1 Like

Hi,

“Open Available Browser Not found Error”

I am also facing the same issue with open available browser, and tried everything described on this thread,
can anybody help me on the issue.

also below are the Logs for this error that i am facing

Hi, can you show your conda.yaml -file? IT may be that there is something wrong with RPA Framework library.

@Teppo
here it is

:thinking: Can you try changing the Library RPA.Browser to Library RPA.Browser.Selenium (in .robot -file) and test what happens?

Thanks,

Tried but still having the same issue, its something with the RPA library but i am not able to figure it out.

This error you are getting is caused by rpaframework not being installed in the environment. However, your conda.yaml shows that it should be installed. Does it work if you run it with “Run Robot” button in the top right corner? If it doesn’t work, does the log show any errors during environment setup?

Hi,

I am also facing same issue as above