Nothing provides vc 9.* needed by python-2.7.12-0

Hi

Having issues building environment when using below conda.yaml file. I’m using the Robocorp plugins in VSCode. Robocorp Code v0.16.0 & Robot Framework Language Server v0.24.0 & RCC v10.7.1 is installed. Running under Windows 10.0.18363 Build 18363

VSCode is version 1.61.1

The error:

ERROR Could not solve for environment specs

lsp: 2021-10-17 19:09:54 UTC pid: 25624 - MainThread - EXCEPTION - builtins
Error getting interpreter info for: file:///c%3A/Users/duncan/github/<repo>/CreateZSPOSalesOrder/tasks.robot

Traceback (most recent call last):
  File "c:\Users\duncan\.vscode\extensions\robocorp.robocorp-code-0.16.0\src\robocorp_code\plugins\resolve_interpreter.py", line 444, in _compute_base_interpreter_info_for_doc_uri
    return _CacheInfo.get_interpreter_info(
  File "c:\Users\duncan\.vscode\extensions\robocorp.robocorp-code-0.16.0\src\robocorp_code\plugins\resolve_interpreter.py", line 242, in get_interpreter_info
    ] = _CachedInterpreterInfo(
  File "c:\Users\duncan\.vscode\extensions\robocorp.robocorp-code-0.16.0\src\robocorp_code\plugins\resolve_interpreter.py", line 122, in __init__
    raise RuntimeError(f"Unable to get env details. Error: {result.message}.")
RuntimeError: Unable to get env details. Error: Environment from broken conda.yaml requested: c:\Users\duncan\github\<repo>\CreateZSPOSalesOrder\conda.yaml.

conda.yaml file:

channels:
  - conda-forge

dependencies: 
  - python=3.10.0

  - pip=21.3
  - pip:
    - rpaframework==11.4.0

The cause based on the output seems to be:

Encountered problems while solving:

  - nothing provides vc 9.* needed by python-2.7.12-0

Not sure what is looking for vc 9 or python 2.7.12. I’m guessing vc 9 is the MS C++ Redistributable package but I’m not sure of that.

If I back the python version and pip version down environment loads and works but I have some self created packages on pypi that I’d like to use and 3.10 is required. Any assistance is appreciated.

Python 3.10.0 is really “fresh from the oven” and unfortunately, the majority of packages in PyPI do not yet have compiled packages for that version.

This means a lot of packages would need to be compiled on your machine and for that the compilation toolchains would need to be on your machine.

We heavily recommend older versions of Python for this reason (3.7.5) and we are still looking to get all the dependencies of our rpaframework into conda-forge where the compilations are done by the system.