Open Available Browser Error In Ubuntu

Please help

Open My Browser
    [Arguments]  ${url}

    Open Available Browser  ${url}
    ...  maximized=${True}  
    ...  alias=whatsapp 
    ...  use_profile=${True}  
    ...  headless=${False}

the above code when I run through rcc run or vs code its working fine. but when I run this through cronjob in ubuntu this is going headless mode and shows error

[ WARN ] Profiles are supported with Chromium-based browsers only!
[ WARN ] Profiles are supported with Chromium-based browsers only!
BrowserNotFoundError: Failed to start a browser:
- Chrome: Message: unknown error: Chrome failed to start: exited abnormally.
  (unknown error: DevToolsActivePort file doesn't exist)
  (The process started from chrome location /opt/google/chrome/chrome is no longer running, so ChromeDriver is assuming that Chrome has crashed.)

Our recommended way of running robots is using Worker, and using scheduling on Control Room, where cron-like functionality is available.

When you rely on your OS scheduling, you need to follow guides on your OS on setting those, and problem resolutions is mostly on you.

But if you think this is library problem, then please update to latest rpaframework release, since there have been many browser related updates lately. See our Announcements channel on our slack (

Also, see: Find the Worker setup for you | Robocorp documentation

just now found the solution. When we are using cronjob we need to add Display=:0 after the time

5 * * * * Display=:0 <rest of the code here>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.