Package Problem?

Hallo, i am using Python to learn RPA framework and installed the Framework and just want to open Outlook as Example but i see this Errors why?

Hi! PyCharm probably can not find the rpaframework package. I don’t use PyCharm myself, so can not help with that. If you want, you can try using Visual Studio Code with Robocorp extensions.

1 Like

i did installed already in Terminal
pip install robotframework-selenium2library
and i did RPA challange by Python also Pycharm

What version of rpaframework do you have?

1 Like


i installed but it es here not definde ?

pip install rpaframework

1 Like

There is guide for PyCharm here. And its highly recommended to use Robocorp tooling and templates, you will have much easier start.

2 Likes

Thank You all for the Help, i did it and installed the last Version of Framework, but i just want to use only Python , also translate all codes in python and run it all before i Buy robocop.
just like i want to use this example of sending message but it doesnt work it does no running and sending nothing . i tried this exapmle with OlBody Items and it worked but with framework no. i dont know where the problem is .
image

All development tooling is free to use.
What kind of error you are receiveing? I tried following code without problems:

# """Template robot with Python."""
from RPA.Outlook.Application import Application

def send_message():
    app = Application()
    app.open_application()
    app.send_email(
        recipients='test@outlook.com',
        subject='Test email from robot',
        body='Hello World!')

if __name__ == "__main__":
    send_message()
3 Likes

i tried it now and worke. i understanded all but this why it es referenz on main?
image

2 Likes