Pip dependency warning in VSCode

Installed Robocorp extensions for VSCode and created first Robot using it. But both conda.yaml and robot.yaml show a warning

There is 1 pip dependencies. Please, prefer using conda dependencies over pip dependencies.robocorp-code

The code still runs after that but this warning is annoying and I would like to resolve the issue.

Here’s the screenshot of the warning.

Appreciate any help in resolving this issue.

Hi, this is just a warning as said.
We heavily favor getting dependencies from conda-forge as pip is usually the culprit of all sorts of dependency collisions etc. so we added this warning as a “push” a while back.

However, it seems that there is still so much dependency in pip that we will be removing this warning from RCC validation.

Br, Kari