Robocorp Code: Unable to create environment

I have been working on VS code and extensions provided by robocorp for a month now. In local system it is working fine but now while trying to shift the development to windows server I’m facing some errors. Tried with the solutions i had tried out in local system but didn’t work.
Initially All RPA libraries are recognised but when trying to use custom Python library which contains importing of libraries like numpy, pendulum, prettytable all RPA libraries are not recognised and only inbuilt libs(Datetime,String etc) are working.

This is my conda.yaml:
channels:

Define conda channels here.

  • conda-forge

dependencies:

Define conda packages here.

If available, always prefer the conda version of a package.

Installation will be faster and more efficient.

Search :: Anaconda.org

Not mentioned versions of libs in conda.yaml as this same method worked in local.Didn’t work even when versions were specified
Also while obtaining environment got this error
Error:
There was an error creating the environment for:
“c:\test\Bot_Name\conda.yaml”

Error running: c:\Users\UserProfile.vscode\extensions\robocorp.robocorp-code-0.34.0\bin\rcc.exe holotree variables --space vscode-09 c:\test\Bot_name\conda.yaml --json --controller RobocorpCode.
ROBOCORP_HOME: None

Progress: 05/13 v11.9.16 0.049s Running micromamba phase.

Fatal [Micromamba [1/1]]: exit status 1
— installation plan 2022-06-20T07:27:40-07:00 [force: false, fresh: true| rcc v11.9.16] —
critical libmamba Download error (7) Couldn’t connect to server [https://conda.anaconda.org/conda-forge/noarch/repodata.json]
Failed to connect to conda.anaconda.org port 443 after 2010 ms: Connection refused
[N] Retry! First try failed … now retrying with debug and force options!
info libmamba Starting to download targets
info libmamba Download error (7) Couldn’t connect to server [https://conda.anaconda.org/conda-forge/win-64/repodata.json]
Failed to connect to conda.anaconda.org port 443 after 2119 ms: Connection refused
info libmamba Download error (7) Couldn’t connect to server

Any sugestions would be great

If you are behind proxy/firewall, you should check these instructions: Firewall and network proxy requirements

Also note minimum requirements for servers.

1 Like

Yes, before setting up proxy and rcc profile, was not able to download even Salesdata.xlsx file while running course 1 code, but then, the proxy was set and and was able to download files. So, the proxy has been set and firewall is also disabled to check if that is the issue but still same error.

Yes, checked that as well and server meets the requirements.

Hi,

If you get RCC from: https://downloads.robocorp.com/rcc/releases/v11.9.10/windows64/rcc.exe
… and run: rcc config diagnostics
Does that show any errors or warnings?
Normally setting the proxy settings only affect the browsers and not the command-line level.

The error:
Download error (7) Couldn’t connect to server [https://conda.anaconda.org/conda-forge/noarch/repodata.json]
…points to either the proxy blocking the connection OR that it is a MITM proxy that cuts the HTTPS certificate chain. Basically does the proxy only support HTTP traffic?

If you are already using (RCC profile configs](rcc/profile_configuration.md at master · robocorp/rcc · GitHub) you can also use that to give a client certificate OR even disable the HTTPS checkups… though this is not the main recommendation.