Robocorp Lab cannot be started with the following error message: RCC Error: Failed to execute rcc process

Hello,
Last week I have installed the latest version of Robocorp Lab - 4.4.13 BETA, and I was trying to open an executable file, which did not open.
Therefore, I thought that there is a problem with the application version(since one of my colleagues which has one of the previous versions can open an executable file), I have installed previous version of the Robocorp App (v. 4.2.7), which while installing was updated to the latest version 4.4.13 BETA.
When the application is started, a window with the following error appears: “RCC Error: Failed to execute rcc process. (RCC_10_10) Error: connect ECONNREFUSED 127.0.0.1:19437”.
After that I have uninstalled the app, and installed it again, but right now, neither of the two versions is working.
Please let me know if you have any solution/suggestion for this issue.
Thanks.

Hi, I assume you are running on Windows?
We hit a bunch of these errors in the last release and most of the problems seem to stem from Windows long filename support. We are adding a pre-launch check for this in the next version, but for the time being we added guides for this.


…if this setting was off when you installed you need to run the full uninstall cycle guided here:

…as some files behind paths that are too long are just broken in a way that conda and RCC are not able to fix.

Sorry for the hassle.

Please note that if you are working with IT -department it would be best to have them set this up as a common Group Policy on all Windows machines. The 260 character filename length limit is quite obsoleted and trying to work with python packages and isolated run environments like conda inside that limit is just not feasible.

Hi Kari,
I am running on Windows, and I have already tried the solutions before you proposed them to me, but still the same is happening.
Do you have any other solutions, or I should wait until there is new release? By the way, when there will be a new release?

Thanks!

Hello Dragana,

There will be a new release this week, probably on Wednesday-Thursday. Hopefully it will fix your problem. I’ll check with Kari if there are any other solutions before that.

Saana

Hi Saana,
The problem is solved. The app is working fine. Thanks!

1 Like