Robocorp Lab v4.20.4 released

A big update this time, so just picking the headings from full release notes here:

  • New UX
  • New Locators implementation
  • New “Scratchpad” for REPL style testing
  • All-new “basement”

…release notes contains a gif that gives a quick guide to the new UX.

1 Like

@Kari After updating the sidebar icons are missing. Tried reinstalling also but the same problem. If I hover it its showing the tooltips but the icons are not showing.

Hi,

Are you running on windows / mac / linux? Have a couple of other detailing questions so if possible can you submit an issue via Labs Get Help > Submit Issue so that we get the platform details down.

The logs might also help us to rule out one thing I have been tracking which is a few cases where Electrons auto-updater seems to just fail silently.

BR, Kari

@Kari I am using Windows. Already submitted the issue #839.

Hi,
Yeah sorry, just spotted your ticket and checking the logs.

No problem, thank you.

I have one workaround to test that is a bit on the strange side.

Electron applications on Windows store some of their “own stuff” under
C:\Users\{username}\AppData\Roaming -folders
This it seems can include styles/images.

So if possible you could try the following:

  • Close Robocorp Lab
  • In File Explorer open: %appdata%
    • This should take you to C:\Users\{username}\AppData\Roaming\
  • Rename the folder robocode-lab to something like robocode-lab-temp
  • Restart the Lab
    • If the Recent robots list does not update on 1st start close and re-open Lab
    • … this blob cache is a bit weird :thinking:
  • Open a robot

This is a weird one, I hope this helps you out, but on the other hand if this is the cause then we have some digging ahead for us :sweat_smile:
In any case please ping if whether this helps or not.

Br, Kari

Hi, yes after following the above steps it’s now showing.

Capture

Great!

…now we just need to figure out how that thing storage things works and how to control it :wink:

Thanks a lot for the support. I am new to RPA and planning to turn my career to this field. And also is there a way to change the default directory of ROBOCORP_HOME. I tried searching in setting but couldn’t find it.

Hi, you can define it via environment variables.

…but you are that this probably could also be in application settings, we’ve just seen this as a troubleshooting feature against the “spaces in paths” -problems.

wonderful, thank you :slight_smile: