Robot Framework: chrome browser don't work when I run a program basic (I used vscode)

I create a program open browser Chrome (I used robot framewoek on IDE vscode), but error when run program:

file conda.yaml:

channels:
  # Define conda channels here. 
  - conda-forge

dependencies:
  # Define conda packages here. 
  # If available, always prefer the conda version of a package, installation will be faster and more efficient.
  # https://anaconda.org/search  
  - python=3.7.5

  - pip=20.1
  - pip:
    # Define pip packages here. 
    # https://pypi.org/
    - rpaframework==10.3.0 # https://rpaframework.org/releasenotes.html

file tasks.robot:

*** Settings ***
Documentation     Robot to enter weekly sales data into the RobotSpareBin Industries Intranet.
Library           RPA.Browser.Selenium

*** Keywords ***
Open The Intranet Website
    Open Available Browser    https://robotsparebinindustries.com/

*** Tasks ***
Insert the sales data for the week and export it as a PDF
    Open The Intranet Website

Error after run program:

==============================================================================
Tasks :: Robot to enter weekly sales data into the RobotSpareBin Industries...
==============================================================================
ERROR: The system was unable to find the specified registry key or value.
Insert the sales data for the week and export it as a PDF             | FAIL |
BrowserNotFoundError: Failed to start a browser:
- Chrome: File is not a zip file
- Firefox: [Errno 13] Permission denied: 'C:\\Users\\VIET\\AppData\\Local\\robocorp\\webdrivers\\geckodriver.exe'
- Edge: expected str, bytes or os.PathLike object, not NoneType
- Ie: 'NoneType' object has no attribute 'group'
- Opera: Message: unknown error: cannot find Opera binary
  (Driver info: operadriver=92.0.4515.107 (87a818b10553a07434ea9e2b6dccf3cbe7895134-refs/branch-heads/4515@{#1634}),platform=Windows NT 10.0.19042 x86_64)
------------------------------------------------------------------------------
Tasks :: Robot to enter weekly sales data into the RobotSpareBin I... | FAIL |
1 task, 0 passed, 1 failed
==============================================================================
Output:  f:\training python\Example\output\output.xml
Log:     f:\training python\Example\output\log.html
Error: exit status 1

Can you help me? Thanks you very much!

Could you submit and issue from VSCode, so that we can further investigate this?

Couple of extra question:

  • What is the version of Chrome is available in your system?
  • Are you in a corporate environment with e.g. limited access rights to c:\ drive?

One thing you could try is delete everything chrome related from: C:\Users\VIET\AppData\Local\robocorp\webdrivers\

It should force the reloading of chrome web driver in next run and hopefully get a correct zip file.