RPA.Desktop.windows cannot be imported at windows10

I’d like to import RPA.Desktop.windows at windows 10, but it doesn’t work.

Here is some sources.

  1. conda.yaml
- conda-forge
- python=3.9.13
- pip=22.1.2
- pip:
	- rpaframework==22.0.0
	- rpaframework-windows==7.0.2
  1. tasks.robot (I wrote)
*** Settings ***
Library          RPA.Desktop.Windows
Suite Teardown   Close all applications

*** Tasks ***
Open Calculator using run dialog
    ${result}=              Open using run dialog    calc.exe   Calculator
    ${result}=              Get Window Elements
    Send Keys               5*2=
    ${result}=              Get element             partial name:Display is
    Log Many                ${result}
    ${result}=              Get element rich text   id:CalculatorResults
    Should Be Equal As Strings  ${result}  Display is 10
    ${result}=              Get element rectangle   partial name:Display is
    ${result}=              Is Element Visible      CalculatorResults
    ${result}=              Is Element Enabled      partial name:Display is```

I've tried to change environment PATH and python install location, but nothing happens.


I’ve tried to run this example without any issues. If you use Robocorp tooling there is no need to change anything. Can you also share the error you are getting?

Here it is the image!

RPA.Desktop.Windows got deprecated in favor to RPA.Windows. (Read more)

1 Like

There is error about environment building on your screenshot. Are you sure that robot environment got built correctly?

1 Like