RPA.Dialogs empty popup error

Hey,
I am trying to complete the Level II Robocorp certification task on Arch Linux that requires the use of the RPA.Dialogs library but unfortunately I can’t get it to work. After reading this other thread here: Error when using RPA.Dialogs I managed to set up conda.yaml properly and solve the Qt/GTK error however this is the popup that I see now:
image
As you can see it doesn’t contain any fields inside of it. Others have tested my code on other systems and apparently they don’t have these problems. I also tried downloading some other RPA.Dialogs robots from the Robocorp repository and they generate the same error. I tried installing pywebview at the system level as well, but that didn’t solve it.
Here’s my conda file for reference:

channels:
  # Define conda channels here.
  - conda-forge

dependencies:
  # Define conda packages here.
  # If available, always prefer the conda version of a package.
  # Installation will be faster and more efficient.
  # https://anaconda.org/search
  - python=3.10.5
  - qt=5.12.9
  - pyqt=5.12.3
  - pip=22.2.2
  - pip:
      # Define pip packages here.
      # https://pypi.org/
      - pywebview[qt]==3.6.3
      - rpaframework==15.8.0 # https://rpaframework.org/releasenotes.html

Any ideas how to solve this? Thanks.

P.S.
I may be missing some Qt building blocks that pywebview needs for the UI but I am not sure which ones.

Hello @stan!

Unfortunately RPA.Dialogs is best suited for Windows and Mac.On Linux all these issues get very complicated, so at the moment we only support Ubuntu. It’s really hard to debug and properly target these types of issues because of all the dependencies needed on Linux and because of how complicated QT is. What I can tell you though and it won’t help right now, but it might later on: We are looking at ways to make RPA.Dialogs more robust and eliminate all these types of issues. It might take a while to get there, but it is definitely on our roadmap.

1 Like