RPA Robocloud Items (local testing)

Hi Experts,

I am using Robocorp Lab (on a Mac M1) and testing work items running locally.
I have followed the data pipeline tutorial

But when attempting to read the local items I receive the error in the log:
“No active work item” when attempting to access variables via “Get Work Item Variable” (or look at payload)

I have triple checked the json file, the env.json settings etc.

Is there some initialization that I am missing?

Thanks in advance, Warren

Hi @warrene

I just tested it.
In my env everything worked fine.


Did you adapt the value of RPA_WORKITEMS_PATH?
Could you share your code with us?

1 Like

Thank you for your assistance, I created a simple project (like you did) and all seems to work.

I copied my env.json file across to my more complex project and that seemed to fix the issue. I can only assume that I have some formatting issues with it :man_shrugging:. I initially thought that there may be some permission errors or file escape issues (I am on mac, rather than windows as you are). I had also switched from using VS Code to Robocorp Lab due to other compatibility issues.

TL:DR → Lots of challenges getting M1 to work with VScode etc.

Thanks again Warren

1 Like

@warrene: Have you tried with February 2021 (version 1.54) release of Visual Studio Code? Those notes state:

Thank you @jani for the pointer, I was still using the “insiders” version, will test out the new stable build and see if I can “revert back” to using VS code for the robot development.

image

Regards,
Warren