Stuck on Beginners' course

Good evening everyone,
After developing with GUI RPA tools for some time i’ve made the decision to invest my time in Robocorp and am now taking the first steps.

That being said i’m ironically stuck at the “Hitting a roadblock” section:

I copy/pasted the code exactly how it’s written in the tutorial but for some reason my *** Tasks *** cell does not seem to finish compiling to the end.
Here is a screenshot:

Spinning weel never goes away even after the Kernel goes idle and i can’t see the log indicated in the tutorial.

Can anyone give me any ideas on what might be happening? Thank you so much in advance

Hi, @JimmyYung! Based on your screenshot the task is stuck when running the Open Available Browser keyword.

One thing to check is to see if there’s an update for the browser you are using and install that. Sometimes the browser and the driver version (for example Chrome and chromedriver) get out of sync if there is an update you need to install.

If that does not help, one option is to try and reopen Robocorp Lab.

The last resort is to reboot your computer. That should get rid of any stuck processes and might fix the issue.

If none of that helps, ping us and we try to get you unstuck!

1 Like

Sorry for the late response and thank you so much for taking the time to help me out.
Okay so i’ve reeboted both Robocorp Lab and my computer, it didn’t work.

This is the output from the Create Table command:

This is my code to read the indexed columns (just like in tutorial, please note how i convert from indexed value to string)

(continues on another comment)


And this is the output of robocorp:

I also tried indexing the values with numbers instead of their name, it didn’t work either:

Output result:

I feel like i’m really close but some technical problem or formality is stopping the bot from operating like in the tutorial. Sorry for the imgur links but it didn’t let me upload to this board.
Thank you in advance, all the best.

Hi, @JimmyYung! Let’s get you unstuck.

Can you share your full robot code? From your screenshot, I see you are using Second Name instead of Last Name to access the last name column. This leads me to think if there might be some other differences in the robot code compared to the one in the course.

I just tried with the exact code from that chapter and it seems to work ok.

EDIT: I think I know what’s wrong. I did some testing. The loop code that goes through the rows in the table should look like this:

FOR    ${sales_rep}    IN    @{sales_reps}

Note the @ instead of $ when referring to the sales_reps table. The @ character is used with list-like objects in FOR loops, for example. The $ refers to the table object as is. The @ refers to the items in the table, and this is what you want to do here.

I tried changing @ to $ and got the same error you got:

This is the incorrect syntax!

FOR    ${sales_rep}    IN    ${sales_reps}

So, try with @{sales_reps}. This is one of those Robot Framework “things” when referring to list-type variables:


Hi @jani

Similar to what @JimmyYung is facing

I am also facing same issue

I think it is something a bug

Because even when I close all application and browser it is still showing like this

Can u please check ?

Works on Chrome 89.0.4389.82. There have already been two updates for the stable version of desktop Chrome this month, so it is a good idea to check if you have those installed.

Hi @jani

my chrome version is image same

Good morning @jani
THANK YOU so much, it was indeed the @ instead of the $ to loop through the Excel entries.
I can’t believe you were able to detect the issue without the copy of the code, good job!

I will proceed with the rest of the tutorial, love the framework and the assistance was super super cool and helpful.

My best regards,

PS: @Nived_Nambiar try the solution and if you can’t make it work please send me a private message maybe i can help :slight_smile:


I am also getting the same error even after double - checking the complete .robot file for mistakes. It is exactly same as that of the Tutorial.
In my case -

  1. correct screenshot is generated
  2. output PDF file is totally incorrect
  3. the .robot is in infinite loop. (Code here - Robocorp Tutorial I Error -

Request your help… Thanks


Hi Good day everyone, i’m just a newbie just a few hours old in this world also im not sure if im in the right space.

Anyone having the same trouble as above and how do you resolve it? Thank you!

1 Like

Hello, yes, i absolutely have a solution for that, i’ll link it as soon as possible !

If you’re just looking for a simple fix for that error, just use another Excel you download from the internet to get through the tutorial that has another encoding

If you really want to use your current Excel to finish the tutorial, I had the same exact issue on another thread, can you please look into it and if you have any doubts/questions get back to me? 100% no error run on Lab, error on Cloud - #7 by JimmyYung

Cheers, all the best

1 Like

Hi Jimmy, Thank you for the help testing it out right now!

1 Like

Hi I seem to be having the same issues as @praveenkumarnitp
I have done all suggestions I have seen here, would any have any other tricks I could try?

Have you also updated your rpa-framework to latest version(10.8.0)? If not then you can try that, it can be done in conda.yaml file.

FYI: The PDF generation should work better now.