Unable to execute the basic template

Hi all…
I have created a basic robot using the Robocorp: Create Robot and the basic template but when i try to run my robot i get this message:

Unable to resolve interpreter for: /Users/carvalho/Library/CloudStorage/OneDrive/RPA/rsb-robot/robot.yaml

What i need to do to be able to run this robot ? The only that i changed was the python version on conda.yaml because the default version uses the 3.7.5 python but with that version i get this message:

Invalid python version for workspace folder ‘rsb-robot’. Only python version >= 3.8 supported. Please update to a newer python version or select a valid python environment.

So i changed the version to match the python version of my system:

carvalho@AMAC02FKPF ~ % python --version
Python 3.9.12

Files:
conda.yaml

channels:
  - conda-forge

dependencies:
  - python=3.9.12

  - pip=20.1
  - pip:
      - rpaframework==14.0.0

robot.yaml

tasks:
  Run all tasks:
    shell: python -m robot --report NONE --outputdir output --logtitle "Task log" tasks.robot

condaConfigFile: conda.yaml
artifactsDir: output
PATH:
  - .
PYTHONPATH:
  - .
ignoreFiles:
  - .gitignore

tasks.robot

*** Settings ***
Documentation       Template robot main suite.


*** Tasks ***
Minimal task
    Log    Done.

How are you running the robot? Using RCC or VSCode?

I`m following the robocorp beginners course and in this course they show two ways to run the robot.

1- Using robocorp code extension (in vscode)

2- Using the vscode command palett

either way i get the same result.

Hi! Can you try storing your robot outside OneDrive? I remember seeing some issues with OneDrive back in the day. Not sure if this is similar. Has to do with some path mapping failing somewhere.

Does not look like the same issue, but the one common nominator seems to be OneDrive.

Hi @jani ! Tried your suggestion but got the same message:

Unable to resolve interpreter for: /Users/carvalho/Documents/rpa/rsb-robot/robot.yaml

Hi! Can you try running the robot once more paste the full text output from Output → Robocorp Code?:

It includes a lot of debug information that might be useful.

How are you trying to run this? Trying to resolve interpreter for “robot.yaml” sounds really strange thing to me.

Is there now some other plugin in your editor that is trying to do something with “robot.yaml” files?

This error message indicates, that there is “something else” now running interference on tooling.

Is this some Mac environment where system python is tried to be used? Our environment do not have such limitations, 3.7.5 should be totally valid still.

Nothing…

Dont know if i have another plugin trying to do something with yaml files. Thats what i have installed:

Can you post the contents you have in:

OUTPUT > Robot Framework

@jippo i`m running on a Mac

if i try to run using… i just stopped the typing here…

I edited my conda.yaml back to 3.7.5 to get the message again and guess what ???

@fabio i just executed it with no problems now… dont know why…

Ok. So now you seem to have working setup! Right?

yep! Thanks all for the efforts