VS Code and Robocorp Code don't like my Ubuntu 22.04.3 LTS install

Somehow VS Code, Robocorp Code and my Ubuntu don’t get along.

I started with the snap version of VS Code and tried to follow “Robocorp Level I Certification: Python”.
Hello world worked but browser would not launch.

Uninstalled the snap VS Code and got the deb from the official page.

Still same problem:

Collecting tasks from: tasks.py
======================= Running: robot_spare_bin_python ========================
    this._firstNonInitialNavigationCommittedReject(new Error('Page closed'));

Error: Page closed
    at FrameSession.dispose (/home/myuser/.robocorp/holotree/75dd210_b1f3c24_6133770e/lib/python3.10/site-packages/playwright/driver/package/lib/server/chromium/crPage.js:492:52)
    at CRPage.didClose (/home/myuser/.robocorp/holotree/75dd210_b1f3c24_6133770e/lib/python3.10/site-packages/playwright/driver/package/lib/server/chromium/crPage.js:152:60)
    at CRBrowser._didDisconnect (/home/myuser/.robocorp/holotree/75dd210_b1f3c24_6133770e/lib/python3.10/site-packages/playwright/driver/package/lib/server/chromium/crBrowser.js:216:57)
    at CRConnection.<anonymous> (/home/myuser/.robocorp/holotree/75dd210_b1f3c24_6133770e/lib/python3.10/site-packages/playwright/driver/package/lib/server/chromium/crBrowser.js:94:81)
    at CRConnection.emit (node:events:517:28)
    at /home/myuser/.robocorp/holotree/75dd210_b1f3c24_6133770e/lib/python3.10/site-packages/playwright/driver/package/lib/server/chromium/crConnection.js:84:39

Node.js v18.18.0
<Condition(<unlocked _thread.lock object at 0x7ffbf7a3fe80>, 1)>
<BrowserContext browser=<Browser type=<BrowserType name=chromium executable_path=/home/myuser/.robocorp/playwright/chromium-1084/chrome-linux/chrome> version=119.0.6045.9>>

Tried to clean and rebuild all with the two obvious command in VS Code and also deleted ~/.robocorp once.

Tried to use examples like GitHub - robocorp/example-playwright to rule out my robot but only got more strange conda errors and failures.

Does anybody have any idea, what’s wrong with

# For more details on the format and content:
# https://github.com/robocorp/rcc/blob/master/docs/recipes.md#what-is-in-condayaml
# Tip: Adding a link to the release notes of the packages helps maintenance and security.

  - conda-forge

  - python=3.10.12                # https://pyreadiness.org/3.10
  - pip=23.2.1                    # https://pip.pypa.io/en/stable/news
  - robocorp-truststore=0.8.0     # https://pypi.org/project/robocorp-truststore/
  - pip:
    - rpaframework==27.5.2        # https://rpaframework.org/releasenotes.html
    - robocorp==1.2.4             # https://pypi.org/project/robocorp
    - robocorp-browser==2.2.1     # https://pypi.org/project/robocorp-browser

from robocorp.tasks import task
from robocorp import browser

def robot_spare_bin_python():
    """Insert the sales data for the week and export it as a PDF"""

def open_the_intranet_website():

Diagnostics looks OK to me:

$ /home/myuser/.vscode/extensions/robocorp.robocorp-code-1.12.0-linux-x64/bin/rcc diagnostics
 - ENV:ComSpec                           ...  ""
 - ENV:LANG                              ...  "de_CH.UTF-8"
 - ENV:SHELL                             ...  "/bin/bash"
 - ROBOCORP_HOME                         ...  "/home/myuser/.robocorp"
 - config-active-profile                 ...  "default"
 - config-http-proxy                     ...  ""
 - config-https-proxy                    ...  ""
 - config-micromambarc-used              ...  "false"
 - config-piprc-used                     ...  "false"
 - config-settings-yaml-used             ...  "false"
 - config-ssl-no-revoke                  ...  "false"
 - config-ssl-verify                     ...  "true"
 - controller                            ...  "rcc.user"
 - cpus                                  ...  "4"
 - dns-lookup-time                       ...  "DNS lookup time for 9 hostnames was about 0.160s"
 - executable                            ...  "/home/myuser/.vscode/extensions/robocorp.robocorp-code-1.12.0-linux-x64/bin/rcc"
 - hololib-catalog-location              ...  "/home/myuser/.robocorp/hololib/catalog"
 - hololib-library-location              ...  "/home/myuser/.robocorp/hololib/library"
 - hololib-location                      ...  "/home/myuser/.robocorp/hololib"
 - holotree-global-shared                ...  "false"
 - holotree-location                     ...  "/home/myuser/.robocorp/holotree"
 - holotree-shared                       ...  "false"
 - holotree-user-id                      ...  "75dd210"
 - installationId                        ...  "1d6c1bba-f5db-cc01-a469-acdf45f29b01"
 - lock-cache                            ...  "/home/myuser/.robocorp/rcccache.yaml.lck"
 - lock-config                           ...  "/home/myuser/.robocorp/rcc.yaml.lck"
 - lock-holotree                         ...  "/home/myuser/.robocorp/holotree/global.lck"
 - lock-robocorp                         ...  "/home/myuser/.robocorp/robocorp.lck"
 - lock-userlock                         ...  "/home/myuser/.robocorp/holotree/75dd210_5a1fac3_9fcd2534.lck"
 - micromamba                            ...  "1.4.9"
 - micromamba.bin                        ...  "/home/myuser/.robocorp/micromamba/v1.4.9/micromamba"
 - no-build                              ...  "false"
 - os                                    ...  "linux_amd64"
 - os-holo-location                      ...  "/opt/robocorp/ht"
 - rcc                                   ...  "v16.5.0"
 - rcc.bin                               ...  "/home/myuser/.vscode/extensions/robocorp.robocorp-code-1.12.0-linux-x64/bin/rcc"
 - telemetry-enabled                     ...  "true"
 - tempdir                               ...  "/tmp"
 - timezone                              ...  "CET"
 - tls-lookup-time                       ...  "TLS verification time for 9 hostnames was about 1.709s"
 - tls-proxy-firewall                    ...  "undetectable"
 - uid:gid                               ...  "1000:1000"
 - user-agent                            ...  "rcc/v16.5.0 (linux amd64) rcc.user"
 - user-cache-dir                        ...  "/home/myuser/.cache"
 - user-config-dir                       ...  "/home/myuser/.config"
 - user-home-dir                         ...  "/home/myuser"
 - when                                  ...  "2023-11-16T21:47:12+01:00 (CET)"
 - working-dir                           ...  "/home/myuser/git/my-rsb-robot"


Ubuntu changing into SNAP packages makes a lot of things and tooling severely hard. Simply but the Ubuntu based distros since 18.04 are just way too hard for us to support at this time.

We have moved all of our containers to be Debian based for this reason and we are looking for a replacement distro to handle the Linux Desktop side… which is proving quite hard.
…which is why unfortunately our system recommendation for Linux desktop is still Ubuntu 18.04 which is eol.

Realistically we cannot offer direct support for multiple Linux distros, so we need to pick and choose, but both the Robocorp Code - VS Code extension and RCC are fully open-source tools and we welcome contributions.

BR, Kari

Hi Kari,

This is why I removed the snap and installed the deb version of VS Code, the moment I encountered the fist problem.

Your link states “Ubuntu 18.04 or later” so I should be good?

Shouldn’t conda take care of all the stuff and abstract the OS away as far as possible?

TBH, I also tend to go back to Debian as I start to get fessed up with snaps or go wild and go with GUIX/Nix for some thing “new”.

Also in slack I got asked, if this is Ubuntu inside of WSL, it’s not.

BR, Dominik

Yeah we are in the process or rewriting the system requirements page.
…turns out to be one of the most challenging docs -page there is :sweat_smile:.

TBH, did not even realize we still have the “or later” part there, so big thanks for the ping on that, we need to fix that asap.

Are you able to use the Submit Issue -action from our VS Code extension panel? That would get the logs we need to us securely to look a bit deeper. But at the moment we cannot promise support for Ubuntu 22.04 unfortunately.

BR, Kari

1 Like