VS Code Extension: Conda Error

Was trying to build the robocorp bots using the VS code extension.
The extensions itself gets installed without any errors.
But, when the command Robocorp:Create Robot is run, the below error occurs at the conda installation step.

From checking out the source it may have been caused due to the space in the username.
But, when I tried to manually install conda using the conda.exe , it gets installed successfully.
The conda installation was also verified. The conda list and conda version would provide outputs without any error.

After this, reinstalled the extensions, restarted VS code and ran the create robot command again, but it throws the same error every time.

Even tried to manually install rcc from command line, but the same issue would occur.

Has anyone seen this issue before who can guide me if I am doing something wrong and help me resolve this issue.

Hi,
Spaces and special characters in the users path have been a long standing issue and they are currently breaking the internals of MiniConda and and also pip on Windows in one way and on Linux/Mac another way.

The fix for this at the moment is to set an environment variable ROBOCORP_HOME to point to a folder that does not have weird characters in the path.
For example: ROBOCORP_HOME=C:\Tools\robocorp ensures that the file paths work with the underlying tools.

We are coming out with an update to RCC and Robocorp Lab this week to address this in those tools and VsCode extension will follow soon after.

Best regards,
Kari

1 Like

Hey @Kari ,

Thank you for the update regarding the fix.

Meanwhile, for the workaround, I have changed the ROBOCORP_HOME to point to a different folder.
image

However, for the conda installation it picks the users AppData folder by default and throws an error.
Is there any other workaround to change the conda installation path or to skip this step if conda is already installed manually.

Regards,

Hi and a do’h,

So in Robocorp Lab we have the implementation to override the user TMP and TEMP (which by default point to the user folders), but we don’t have that in the VsCode extension.

We are just now starting release test on an RCC that houses the ROBOCORP_HOME logic as well as the TEMP logic as we noticed in our tests that also Linux and Mac machines break-down with spaces. Once that is tested we will upgrade the VsCode as well.

So help is coming soon but if you are willing and eager to work with another workaround then you can point your TMP and TEMP environment variables to for example D:\TEMP. Note that you have to set both of those.
Please note a few things though: This will move the system-wide temp location which means your TEMP folder is visible to other users on the same machine. This is not usually an issue, but there is a security aspect here if you have multi-user machines.

The upgrades coming will only set these when needed so this work-around is not for all.

Sorry for the hassle,
Kari

Hi,
…going through threads noticed I forgot to ping here the Lab v4.9.11 update now supports ROBOCORP_HOME variable and should take care of the TMP changing as well.