VsCode Python extension acting up, code-completion not working etc

After a bunch of weird cases around pylance and default Python extensions in VsCode I think we have found the reason:

We are looking for a way to work with this or get some API to the Python extension so that we could get our isolated python environments to show up correctly.

So the default python extension is changing and it seems this is now in A/B testing so some people will get it as some won’t, which explains our difficulty in pinpointing the problem.
Now that we got the case to reproduce and tested the Opt-out setting described in the python extensions A/B testing and that should get things working as we are trying to find the solution:

vscode-python-settings

Pinging here as well that we have pushed for the solution to this problem and it is now up for voting to get more eyes from essentially VsCode development side.
…so if you are so inclined additional votes on the issue here from the community would probably help our chances.
:raising_hand_man: :wink: