Workforce Agent service cannot start with local account

Hi Folks, for workforce agent installed on windows 10, if we use a non-admin windows local account, the service will not start. Access is denied. Adding the rights using various methods (processexplorer, powershell, etc) does not seem to work as the process is started as service with NSSM. Any insights will be appreciated.

We can use the local system account but not sure if it is the way to go.


Hello and welcome to forum,

Did you make set up with the help of documentation?

Yes, I followed exactly the steps and the service will not start under a new created local windows account.

I also tried the workforce agent program (UI based), it complains first it will not be able to find the freerdp exe. I moved the portable to the instance folder and then it complains that there is no credentials for the remote desktop connections.

Hi @wirelix
Did you run the service-helper commands logged in as the target user? If you run the commands as another user the permissions and file locations can get mixed up.

We are working on adding these setups to Robocorp Setup Utility to make the setup simpler and also enable the setups from an admin account to other accounts.

BR, Kari

1 Like

Indeed that is the case. Let me try. Thanks.

Addtionally, why the gui workforce agent does not work either?